Symptom
You are receiving unassigned BTM tasks for the notification "Ticket XXX is assigned to you".
The logs say:
- Use action "Assign Item" to manually assign a responsible to the task
- Employees without sufficient access rights for the item:
- Employee: ABC
- Info: Work Center Views that potentially grant access:
- View:Technical: Desktop Navigation (TICKET_DESKTOP_NAVIGATION) - Context: Service Unit (5)
- View:Common Authorizations for Users (CC_COMMONPERSONALWORK) - Context: Personal Work (1004)
- No employee has sufficient access rights
Environment
SAP Cloud for Customer
Reproducing the Issue
- Work center Administrator , view Business Task Management.
- In the "Unassigned" items, you will see tasks like these:
Ticket XXX is assigned to you.
Cause
The following configuration is enabled in the system:
Work center Business Configuration -> Overview -> Business Task Management for Customer Care --> Notifications for Ticket Assignment
Task Type "Ticket <Service Request ID> is assigned to you" is enabled.
Additionally, this is BTM Task Notification which usually shows in the Notifications for users. E-Mails will be triggered if a user subscribes to them from the notification bar (by default, there is no subscription to these emails).
Resolution
This kind of message arises when the user assigned to the respective ticket does not have access restriction to access those tickets.
Please ensure that when a user is assigned to a ticket, they should have access restriction to access the ticket's team as well.
Keywords
BTM, user restriction, ticket assigned to you, unassigned item ticket, service, Employees without sufficient access rights for the item , KBA , LOD-CRM-SRP , Service Request Processing , How To
SAP Knowledge Base Article - Public