Symptom
- After transporting a business role from the development system(Source system) to the test system(Target system), there is a discrepancy in the business catalog count between the two systems.
- In the development system(Source system), the role BR_XXX is successfully imported to the test system(Target system). However, in the test system(Target system), the role BR_XXX has fewer catalogs assigned compared to the development system(Source system). The missing catalogs are present in the test system(Target system) but are not automatically assigned to the role BR_XXX.
Environment
SAP S/4HANA Cloud Public Edition
Cause
The role BR_XXX was imported first, while the scope item was imported later. Since the role was imported before the scope item became available in the system, only the business catalogs associated with the available scope items were synchronized. As a result, only the catalogs related to the available scope item are assigned to the role. However, all remaining business catalogs are present in the system but are not automatically assigned to the role BR_XXX.
Resolution
To resolve this, the business roles BR_XXX should be re-exported from the development system(Source system) and imported into the test system(Target system).
Steps to follow:
- Navigate to the Export Software Collection app in the development system(Source system).
- Search for the collection (YY1_X).
- Click on Export.
- Navigate to the Import Collection app in the test system(Target system).
- Search for the collection (YY1_X).
- Import the collection manually.
Keywords
Business role, Business catalog, test system, Target system, development system, Source system, Mismatch in Business Catalog Count in test system After Transporting Business Role from Development system, Import business role, Export business role, Transport Business role, Export, Import, S4_PC, S4_1C , KBA , BC-SRV-APS-EXT-SL , Manage and Import Software Collections , Problem