SAP Knowledge Base Article - Public

3564223 - Error The Service Catalog Service Is Not Available. Contact SAP Support To Report This Issue

Symptom

When user edits or views an active Case Type in Settings, following error occurs - "The service catalog service is not available. Contact SAP support to report this issue."

Environment

SAP Sales Cloud and SAP Service Cloud Version 2

Reproducing the Issue

  1. Go to Settings.
  2. Search for Cases and navigate to Case Types.
  3. Open active version of an existing Case Type.
  4. Notice that error occurs - 'The service catalog service is not available. Contact SAP support to report this issue.'

Cause

This issue happens when data is not maintained correctly after a tenant copy or refresh.

  1. During Tenant Copy (configuration only), Catalogs are not copied from Source to Target tenant. Catalog have to be created manually or through data impex tool as Catalogs are master data. When full tenant copy is requested Catalogs do get copied from Source to Target.
  2. Case Types are configurations and gets copied from Source to Target. In an Active Case Type, there is a Catalog which is linked to this case type in Source Tenant.
  3. When Case Type screen tried to fetch data on service-catalog in Target Tenant, API returns an error - Cannot find catalog of type HTTP 404, due to which the mentioned error is displayed on screen.

Resolution

Catalog data should be maintained in the system by following below steps:

  1. Go to Settings.
  2. Search for Service Catalogs.
  3. Click on Catalog Definition and create new Catalogs.

Once the catalog is created, ensure that it is linked to the Case Type by following below steps to resolve the error:

  1. Go to Settings and search for Cases.
  2. Navigate to Case Types and click on 'Create New Version' to create a Draft version of Case Type.
  3. In the Draft version, select the new Catalog name in the 'Catalog' field.
  4. Click on Activate.

Keywords

Error, Contact SAP Support, Tenant Refresh, Tenant Copy, Source system, Target system, Catalog, Case Types, Draft, New Version, Service Catalog, Cases , KBA , CEC-CRM-SCA , Service Catalog for SAP Sales/Service Cloud , CEC-CRM-CAS , Case Management for SAP Sales/Service Cloud , Problem

Product

SAP Sales Cloud and SAP Service Cloud Version 2 all versions