Symptom
- Position Vacancy flag is not updated when an employee is terminated via API with job information entity.
- The termination action is correctly captured in the Job Information in SF EC, but the Vacancy Flag on the User's Position is not updated.
- The issue does not occur when the termination action is performed directly within SF EC.
Environment
SAP SuccessFactors Employee Central
Reproducing the Issue
- Initiate an employee termination action in the ERP system.
- Replicate the termination action to SF EC.
- Check the Job Information in SF EC to confirm that the termination action is correctly captured.
- Check the Vacancy Flag on the User's Position in SF EC. The flag is not updated to indicate that the position is vacant.
Cause
The issue arises due to the sequence of API calls during the termination action replication from the ERP system to SF EC. The standard sequence is to first process the Job Information and then the EmpEmploymentTermination. In this sequence, the Vacancy Flag in the Position is not updated. However, if the sequence is reversed, with the EmpEmploymentTermination processed first followed by the Job Information, the Vacancy Flag is correctly updated.
Resolution
Engineering is working to improve the Position Follow-Ups for Job Information import. The fix is planned for 2505 release. This KBA will be updated once the fix is confirmed.
As a workaround, ensure to first import the Termination details via API instead of Job Information.
See Also
2511979 - Employee Central: How Do I Terminate Employees via Import?
Keywords
SAP SuccessFactors Employee Central, Employee Termination, API, Position Vacancy Flag, ERP, Job Information, EmpEmploymentTermination, Sequence of API Calls, Replication. , KBA , LOD-SF-EC-POS-JTP , Job Information to Position Sync , LOD-SF-EC-POS , Position Management , LOD-SF-EC-TER , Termination Details , LOD-SF-EC-EDP-JOB , Job Information Imports , Problem