SAP Knowledge Base Article - Public

3564580 - B2B API Error: Sales Order Creation Fails Due to Address Issue in SAP S/4HANA Cloud Public Edition

Symptom

  • An error occurs while creating sales orders using the B2B API.
  • The error message indicates that the address is not defined for the business partner (BP).
  • The address is not assigned to the partner function.
  • The address is not valid on the current system date.

Environment

SAP S/4HANA Cloud Public Edition

Reproducing the Issue

  1. Use the B2B API for the creation of sales orders.
  2. An error occurs in the AIF Dashboard.
  3. The error message indicates that the address is not defined for the BP, not assigned to the partner function, and not valid on the current system date.

Cause

The address exists but was not correctly assigned to the Ship-to Party (SH) function in the Business Partner Master Data.

Resolution

  1. Open the Business Partner Master Data.
  2. Search for the Business Partner.
  3. Navigate to Partner Functions.
  4. Scroll down to Business Partner and select specific Customer .
  5. Navigate further down to Sales Area and select determined Sales Org.
  6. Click on the "Partner Functions" tab.
  7. Assign the Correct Address.
  8. Click on "Ship-to Party (SH)" for BP XX.
  9. Click on the "Address Description" field.
  10. Select the correct address.
  11. Ensure that it is the Standard Address (Yes) and has Valid Time Frame.
  12. Confirm and Save the changes.
  13. After updating the address assignment, retry the API or IDoc reprocessing.
  14. Create a test Sales Order (VA01) for BP XX and verify that the address is correctly used.

Keywords

B2B API, Sales Order, Error, Address Issue, Business Partner, Partner Function, Address Assignment, SAP S/4HANA Cloud Public Edition. , KBA , SD-SLS-API-2CL , API (Public Cloud) , Problem

Product

SAP S/4HANA Cloud Public Edition all versions