Symptom
You would receive an application error when using joule for : Change , Delete Create , Change Emails
The application error id would be accompanied by Error: The action isn't available right now. This could be due to certain settings not being enabled or permission restrictions.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors HCM Suite
Reproducing the Issue
- Login
- Select user:
- Click on joule
- Click on: View email address
- Issue test: Delete emails , Create emails
- Result:
- Delete emails , Create emails, Change emails not working in joule with error: The action isn't available right now. This could be due to certain settings not being enabled or permission restrictions
Cause
- configuration and permission issue
- This warning indicates instance haven't create the 'Quick Action'
Resolution
This warning indicates instance haven't create the 'Quick Action' template which named 'Change Email Addresses' or user doesn't have permission to access this template.
- Click Here: Joule Capabilities -Employee Central Use Cases
Please created 'Delete addresses ' ,'Change Email Addresses' and 'View Email Addresses' templates which is under 'Manage Data' page,
- About the available templates and how to configure:
After creation Customer need to grant these template to user role :
- Permissions required to set up the templates and to use them:
- Example: 3483830 - Unable to add Employee Central Quick Action for View and Change Emergency Contact in Manage data
Important: Before using the case in Joule, make sure you've configured the corresponding Employee Central Quick Action templates. For more information check below Guide.
Once those templates are configured, and the permissions are granted, the Manage My Data tile will display the quick actions.
NOTE: There isn't a specific permission to control the card display. Once enabled from Manage Home Page, the card will appear to all the users. So, if the permissions for the templates are not granted, the card will appear blank.
- Permissions required to set up the templates and to use them:
FAQ - Additional Information
Q) Where can I get information on this from the Guide?
A) Guide:Implementing Employee Central Core
Chapter: EC: Employee Central Quick Actions
A) Guide: - Joule Capabilities
See Also
- 3390798 - Joule availability in SAP SuccessFactors
- 3564966 - Can I User Proxy action with Joule
- 3531114 - Missing Region and District fields in Quick Action template for Address Change - Unable to Save Address- for Romanian and Hungarian Employees
- 3546768 - Relationship Field no editable in Change Emergency Contacts Quick Action - Employee Central
- 3483830 - Unable to add Employee Central Quick Action for View and Change Emergency Contact in Manage data
- 3399454 - "Manage my Data" Quick Action card does not display content
- 3525188 - Quick Actions: Manage My Data - No response saving changes in Phone Number and Emergency Contact - SAP for Me
- 3497583 - Address Quick action does not show Validate address button - SAP for Me
- 3458083 - Employee Central Quick Actions do not respect field-level permission
- 3540347 - Employee Central Quick Actions for emergency contact or other picklist field are showing external code in the picklist
- 3446147 - Manager field in Quick Action Transfer Template isn't fetching results
- 3540051 - The Quick action template window that pops up does not show the entire error message unless the user clicks on it multiple times
Keywords
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