SAP Knowledge Base Article - Public

3565086 - FSM to C4C Replication Fails with Action FINISH_FULFIL_PROCESS not possible action is disabled

Symptom

When performing a replication from FSM to C4C. At the Web Service Message Monitoring you notice the following error message:
Action FINISH_FULFIL_PROCESS not possible action is disabled 

Environment

SAP Cloud for Customer

Cause

This error is linked to 3 different possible root causes.

Resolution

Root Cause 1 – Change done by user from Finished to Started

In C4C, you have a Ticket ABC with 2 Items (1 item has Work Progress as "Finished" and the other has work progress as "Started"). When Items (Materials) are replicated from FSM they will be in the status Finished (as these were approved materials in FSM) and should not be changed on the C4C side.

This behavior might occur if an user change the status from Finished to Started at C4C side, after the Item was replicated (this is not recommended at all).

For all the items coming from FSM the Item Processing Code will be defaulted by the below rules and should not be changed manually anymore:

Administrator-> Service and Social-> Field Service Management->Define Rules for Product and Item Processing Type. Please notice that these rules are valid for any Item which is created in FSM and replicated to C4C.

Root Cause 2 – Not Relevant Items trying to be updated to Closed

This might happen if you have an Item with the status set as "Not Relevant". Typically, when an Item is added to a Ticket , the Status is defaulted as Open. However, this might be the default status for tickets which you defined for your Process Code (let us suppose you used the standard Sales Order ,defined at Business Configuration set up). However the FSM relevance flag is also set (e.g value 1), which means the replication of item also took place from C4C to FSM, which is a mismatch.

Other Processing Types that are also Not Work Relevant and will make the Ticket Not Work Relevant by default: Consignment Stock, Part Return Pick from Consignment Stock, Customer Item Planning, External Procurement.

In this case, if in the payload, it has been tried to update status to "CLOSED" this will result in an error because the status of the "Not Relevant" item cannot be changed. To change the status of the item, it has to be in Open or Ready state.

To validate this you can go to Tickets for Customer Support BC activity -> Maintain Item Processing Codes. There see the Processing Types being used (e.g “Service Activity” and “Parts” are mapped to “Customer Item Planning “.  This Processing Type is Not Work Relevant by default, hence the error will occur.

Root Cause 3 – You are passing more than one TextCollectionTextTypeCode, but has not maintained any Code List Mapping.

For further details and information, please configure your system according to the following blog: 
https://community.sap.com/t5/crm-and-cx-blogs-by-sap/text-collection-integration-in-cloud-for-customer/ba-p/13343064

Keywords

CSI; Ticket; Activity; Core Systems;  , KBA , LOD-CRM-SRP , Service Request Processing , How To

Product

SAP Cloud for Customer core applications 2411