SAP Knowledge Base Article - Public

3565107 - Enhanced Search stops working after resetting filters

Symptom

After resetting search filters in Integrated Learning Experience, entering a new search term does not generate any results.

Environment

SAP SuccessFactors Learning

Reproducing the Issue

  1. In the Learning Home Page, select any category and hit the search button >
  2. Hit "Reset" in the filters section >
  3. Try to perform another search >
  4. The search does not work and the section displays "Let's get some results" >
  5. The API call returns "200 ok" (available in the browser network traces).

Cause

The issue has been confirmed as a release-related defect from 2H 2024.

Resolution

Our Learning Engineering team has finalized their work on the situation and the fix is targeted to be delivered with the 2505 Learning system version. It is currently being verified the possibility of correcting it via a 2411 patch. Please, set this KBA as a favorite (star icon on the top right corner) to receive updates on it. Check the KBA 2171560 to understand how to get notified when a KBA is created/updated. 

Keywords

Integrated Learning Experience, ilx, search issue, reset, filters, no results, release-related defect, patch, 2H 2024, 200 ok, KI2411, WEF-161059 , KBA , LOD-SF-LMS-ILX , Integrated Learning Experience , Known Error

Product

SAP SuccessFactors Learning 2411