Symptom
The issue reported is that when more than one user open the ticket TI and then without clicking the global edit button if the users start editing some text fields directly.
(Eg: Subject OR if we goto Notes facet and start typing in some notes),
The ticket is NOT getting locked and it allows other users to edit the same ticket when they login from a different device/browser.
Environment
SAP Cloud for Customer
Reproducing the Issue
1.Customer logon with 2 different User and open same Ticket (as an Example) .
2. Edit some text fields which are editable directly without clicking on global Edit button.
Cause
Currently behavior of the functionality.
Resolution
As per the technical implementation done the the UI framework point of view,
we set the LOCK to prevent concurrent changes only if a changes are performed in the Ticket after the Edit button is clicked .
In this particular case what happens is that when we edit the text, no changes are sent. But after editing the text, if we for example navigate to a different facet or trigger any round trip, the change is sent and the ticket instance is LOCKED.
The same behavior can be seen for some code fields too. As per the modeling, if the property 'Requires Round Trip' is set to true, a modification is sent as soon as you make any changes.
But if that property is false, modification is NOT sent immediately.
Keywords
Locked object not working , Ticket TI. , KBA , AP-RC-UIF-RT , UI Framework Runtime , Problem