SAP Knowledge Base Article - Public

3565474 - The signature user could not be determined for role EMPLOYEE_CUSTOM_MANAGER - Onboarding

Symptom

The Complete e-Signature step is not triggered due to Business Process Error:

The signature user could not be determined for role EMPLOYEE_CUSTOM_MANAGER

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors Onboarding

Reproducing the Issue

  1. Navigate to the To-Do panel > Business Process
  2. View document creation errors for onboarding process [PROCESS ID]
  3. Error:
    Document Flow (1)
    Document assignment
    The signature user could not be determined for role EMPLOYEE_CUSTOM_MANAGER

Cause

Cause 1:
The picklist ID/code for the Future Manager Role (jobRelType) is mislabeled.
Cause 2: 
Job relationship not maintained for Onboardee in New Hire Data Review

Resolution

Solution 1:

  1. Rename the picklist ID/code as "jobRelType".
  2. Restart the Business Process error.



Solution 2: 

  1. Configure the Job Relationships section in New Hire Data Review and Assign.
  2. Restart the associated Business Process error, or test with a new onboardee.

See Also

Adding a Picklist Value for Future Manager Role | SAP Help Portal

Keywords

onboarding, onboarding 2.0, obx, complete e-signature, e-signature, not triggered, document flow, The signature user could not be determined for role EMPLOYEE_CUSTOM_MANAGER, EMPLOYEE_CUSTOM_MANAGER, picklist, jobRelType , KBA , LOD-SF-OBX-DOC , Generation of Documents using PFS , LOD-SF-OBX-NHR , Onboardee Data Review , Problem

Product

SAP SuccessFactors Onboarding

Attachments

Pasted image.png