Symptom
The 'Mandatory' field for Playbooks works when enabled, making all the Tasks as mandatory in the Playbook. But when this button is disabled to make the Tasks not mandatory again, it doesn't work as Tasks continue set as mandatory in the list.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Activity Planner > Playbooks.
- Open the desired Playbook and create a list of Tasks under each sales stage.
- Mark the Mandatory button to true in the header, all the tasks are marked as mandatory.
- Now turn the Mandatory button off, the tasks are still marked as Yes under mandatory.
Cause
Once the Mandatory field is set to Yes/On, the Tasks will remain as mandatory even after switching to not-mandatory. This will occur for Tasks that were initially created as non-mandatory and then switched to On, and also for the Tasks already created as mandatory.
The reason for this is, if users create a Playbook as non-mandatory and in the meantime perform some changes in the Playbook that affects the Activities and then switch it off, inconsistencies may happen and impact the created Playbook. To avoid that, development team designed the system this way.
Resolution
This is the expected system behavior.
However, for a different behavior on this, please raise a request in the Influence Site. This is the channel to approach the product management team directly. The feasibility of the request will be evaluated to check whether this can be implemented in a next release or not.
Keywords
KBA , LOD-CRM-SBS-GS , Guided Selling and Playbook , Problem