SAP Knowledge Base Article - Public

3565612 - User is not able to create Contact to Accounts due to error "You are not authorized to create this Contact"

Symptom

User is not able to create a Contact for multiple Accounts or a specific one.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to Customers > Contacts.
  2. Click on new.
  3. Select the desired Account.
  4. Fill the fields and click 'Save and Open'.
  5. Error message "You are not authorized to create this Contact" occurs.

Cause

No access is available/provided for user related to Contacts WoC (work center). It is only proposed but not assigned to the User yet.

Resolution

  1. Go to Administrator > Business Users.
  2. Search for the user > click on Edit > access rights.
  3. Go to Access Restrictions tab.
  4. Select COD_CONTACT_WCV.
  5. In the Detailed Restrictions tab down below, select the user's business role.
  6. Click on Assign Proposed > Add to Existing.
  7. Save

Keywords

KBA , LOD-CRM-CON , Contact , Problem

Product

SAP Cloud for Customer core applications all versions