Symptom
During the integration process between SAP Business ByDesign (ByD) and SAP SuccessFactors Employee Central (SF-EC), duplicate employee records are being created.
Environment
SAP Business ByDesign
Reproducing the Issue
- Follow the SAP Guide (link below) for SAP ByD and SAP SF-EC Integration.
- After ID mapping, replicate the company data.
- Observe the creation of duplicate employee records.
Cause
The issue may be caused by incorrect mapping of IDs. The SAP SF Employee ID has been mapped instead of the SuccessFactors Employee Central Business Partner ID. This incorrect mapping could lead to the creation of duplicate records.
Resolution
- Verify the mapping between the SAP ByD Business Partner ID and the SAP SF-EC Business Partner ID.
- Correct the mapping if necessary, ensuring that the SuccessFactors Employee Central Business Partner ID is used.
- Replicate the data again and check for any duplication of employee records.
See Also
For more details on the correct mapping process, refer to the SAP Business ByDesign and SuccessFactors Employee Central Integration Guide: Maintain ID Mapping
Keywords
SAP ByD, SAP SF-EC, Integration, Duplicate Records, Missing Bank Details, Business Partner ID, Employee ID, Data Replication, HCM-Master Data Replication. , KBA , AP-HMD-RPL , HCM-Master Data Replication , Problem