Symptom
You are unable to make certain fields of the Account (e.g. Country, City, Language) mandatory for Prospects conversion. These fields are not visible under Dynamic Properties, preventing you from adding them. Additionally, when attempting to add a field from the Account service (e.g. account/address/CorrespondenceLanguage), an error occurs stating:
- cannot update any property on account as it is excluded from changes.
Environment
- SAP Sales Cloud Version 2
- SAP Service Cloud Version 2
Reproducing the Issue
- Click on User Icon.
- Go to Settings > All Settings.
- Go to the Extensibility Administration.
- Select Lead Service > Lead.
- Go to the Dynamic Properties tab.
- Click on "+" (i.e., Create Button) > Select Field Attributes.
- In Properties, click on "+".
- Add an Account attribute (e.g. "account/address/correspondenceLanguage").
- Select "Mark as Required".
- Click on Save.
- You can see the following error:
- can not update any property on account as it is excluded from changes
Cause
The issue arises because in Lead Service, account and contact information can pertain to either existing records from master data or local prospect records. Due to this dual nature, metadata level or standard validations for account-related fields have been disabled to prevent conflicts. Validating master data fields would adversely affect the prospect scenario and vice versa.
Resolution
The only way to enforce such field validations is through custom-implemented validations. Unfortunately, the current system setup doesn't support your requirement out-of-the-box due to the inherent design to handle dual scenarios for master and prospect data via Dynamic Properties.
See Also
Keywords
can not update any property on account as it is excluded from changes, Lead, dynamic properties, error, required , KBA , CEC-CRM-LEA , Lead for SAP Sales/Service Cloud , CEC-CRM-CZM-EXT , Extensibility for SAP Sales/Service Cloud , Problem