SAP Knowledge Base Article - Public

3567114 - It's not possible to change the item category for the header level of a BOM item

Symptom

After configuring the activity 'Assign Item Categories' (ID: 102807) for the needed document type and item category group, maintaining the default item category and manual item categories, it's tried to create a sales order for this BOM item.

However, when adding the item and it's quantity, after the BOM explosion happen correctly, the item category field is greyed out for the main item and it cannot be changed.

Environment

SAP S/4HANA Cloud Public Edition

Reproducing the Issue

  1. Open the app 'Create Sales Orders' (VA01).
  2. Enter order type and press enter.
  3. Enter the necessary information.
  4. Enter the BOM item and its quantity and press enter.
  5. Try to change the item category of the main item but the field is greyed out.

Cause

After the BOM explosion it's not possible to change the item category of the main item. This change would result in a new explosion, therefore it's not permitted.

Resolution

To use the manual item category set previously on the configuration activity, input manually the item category before pressing enter. Then, the correct item category will be set before the BOM explosion.

See Also

Sales Order Processing for Sales Kits (31Q)

Keywords

Sales BOM, Sales Kits, BOM explosion, Bill of Materials, Sales Order Processing for Sales Kits, 31Q, item category, manual item category, default item category, manually , KBA , SD-SLS-GF-VA-2CL , Bill Of Material (BOM) & Variant Configuration (Public Cld) , SD-SLS-SO-2CL , Sales Orders (Public Cloud) , How To

Product

SAP S/4HANA Cloud Public Edition all versions