SAP Knowledge Base Article - Public

3567135 - Issue with viewing role details in the Manage Business Partner Master Data app

Symptom

An error message "Navigation is not supported for role xxx" is displayed when attempting to view the details of a specific role assigned to a Business Partner.

Environment

SAP S/4HANA Cloud Public Edition

Reproducing the Issue

  1. Open the Manage Business Partner Master Data app.
  2. Select and open a Business Partner.
  3. Navigate to the roles tab and attempt to access the details of a role.

Cause

The issue arises because viewing other than customer or supplier roles is currently not supported via the Manage Business Partner Master Data App.

Resolution

Maintain Business Partner app can be used to maintain/navigate data for roles other than customer or supplier. 

  1. Go to the Maintain Business Partner app (APP ID: BP).
  2. Search for the business partner.
  3. Navigate to Display in BP role tab.
  4. Select the respective role.

Keywords

SAP S/4HANA Cloud Public Edition, Manage Business Partner Master Data App, Role Details, Navigation Issue, Error Message, Business Partner, Maintain Business Partner App, Role Navigation. , KBA , LO-MD-BP-2CL , Business Partners for Public Cloud , LO-MD-BP , Business Partners , Problem

Product

SAP S/4HANA Cloud Public Edition all versions