Symptom
The user can access to returns in Sales Orders work center, while he is not able to see some of the returns.
Environment
SAP Business ByDesign
Reproducing the Issue
Logon to the system as the affected user.
- Go to Sales Orders work center.
- Go to the Returns view.
- Choose to show all returns, you fond some of the returns are not visible to you. for example return ABC. (ABC represents the ID of the customer return)
You are wondering why the user cannot see the returns.
Cause
The customer return ABC is from Repair at Service Center scenario. You can find this from the customer return notification. The Follow-Up Activity of the line is Repair at Own Service Center. For this scenario, the return requires access to the Service Returns.
You can open the user access rights, the work center view CRM_RETURNS_SERVICE is assigned with restricted access to the user. The assigned organization is XYZ. System checks the access restriction based on the Service and Support Team in the returns, instead of Sales Unit.
In this case in return ABC, the Service and Support Team is not XYZ. Hence, the user is not authorized.
- XYZ represents the organization ID.
Resolution
It is the designed system behavior.
You need to maintain the proper Service and Support Team in the return, so the user can see it.
See Also
2938554 - The User is Not Able to See Some of the Returns
Keywords