Symptom
Error message "Solve Configuration Issue in ID Mapping for Element PARTY_ID-CONTENT with ID 12345" (where ID 12345 means a generic ID) when replicating Registered Products via service interface RegisteredProductReplicationInitiatedByExternalIn.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Administrator work center.
- Go to the General Setting work center view.
- Open the Web Service Message Monitoring under System Administration.
- Select query All.
- Search for message with error "Solve Configuration Issue in ID Mapping for Element PARTY_ID-CONTENT with ID 12345".
Cause
The RegisteredProductReplicationInitiatedByExternalIn process is not functioning because the external ID 12345 does not exist in the ID Mapping for Integration.
Resolution
To resolve this error please replicate an account with the external ID 12345 to C4C. Following that, you can proceed with the RegisteredProductReplicationInitiatedByExternalIn replication.
Also, you can add the ID mapping manually according to the steps bellow:
- Go to the Administrator work center.
- Go to the ID Mapping for Integration work view.
- Click on Edit ID Mapping for Integration.
- Select Mapping Of = ERP Accounts and the System Instance ID.
- Search for desired account and maintain the External ID.
Keywords
RegisteredProductReplicationInitiatedByExternalIn; C4C; Cloud for Customer; Registered Products; Registered; Products; Product; Solve Configuration; ID Mapping; Element PARTY_ID-CONTENT; PARTY_ID-CONTENT; , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , LOD-CRM-INT-S4H , Integration of C4C with S/4 HANA , How To