Symptom
A manager is able to see newly created goals in the Performance Form but not in the goal plan. Additionally, when the manager attempts to add goals to the Performance Form, an error occurs when trying to edit or delete. The error message states: "Record for entity goal with key goal/id=xxxx does not exist." Please verify the key value
Environment
Goal Management
Reproducing the Issue
1.Login to the instance->proxy as manager->Navigate to Goals (Manager view of Employee’s Goals) Manage can see 5 goals
2. Now, Proxy as Employee ->Navigate to goals -> (Employee view of Employee’s Goals) Employee can see 12 Goals
3. Again proxy as manager and navigate to performance->open form for the affected user ->Manage can see all the 12 goals but manager can not edit or delete the goals.
4. When they try to edit or create goals, an error appear as "Record for entity goal with key goal/id=xxxx does not exist".
Cause
The issue appears due to the goal plan's default configuration in regards to visibility. Currently, the goal plan defaults new goals to be created as a "Private goal", which does not have permission access setup in the plan.
Resolution
The configuration needs to be corrected in XML from new-obj-share-status-public="false" to new-obj-share-status-public="True" and Add permissions for "private access" of goals.
EX:-
<permission for="private-access">
<description><![CDATA[Employees and their managers up the hierarchy may view unshared/private goals. Parents of cascaded private goals can see the children.]]></description>
<role-name><![CDATA[E]]></role-name>
<role-name><![CDATA[EM+]]></role-name>
Keywords
GM, Goals ,goal/id=xxxx does not exist, objectives, error , KBA , LOD-SF-GM-ADM , Admin Tools, Settings, Permissions , Problem