Symptom
The timezone displayed in the Background Report Job email notifications may not match the preferred timezone settings of the administrators receiving them.
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Environment
SAP SuccessFactors Learning
Reproducing the Issue
- Schedule a recurring report job in Learning.
- Go to Preferences > Select a Locale and Time Zone section
- Change Time Zone ID.
- Notice that the timezone displayed in the email does not match with admins' timezone preference.
Sample screenshot of Background Report Job Email notification:
Sample screenshot of Admin's timezone preference after timezone is changed:
Cause
The timezone indicated in the email corresponds to the admin's timezone setting at the moment the report was scheduled. This timezone becomes fixed for each scheduled report. Therefore, any subsequent changes to the admin's timezone settings will not affect the timezone of reports that have already been scheduled.
Resolution
- Identify that the timezone in the email notification is the admins' timezone at the time of scheduling the report.
- If a change in timezone is desired, schedule a new report after changing the admin's timezone preference.
Keywords
Timezone, Background Report Job Email Notification, Admin Preferences, report scheduling, admin timezone, user preference. , KBA , LOD-SF-LMS-REP , Reporting Data , How To
SAP Knowledge Base Article - Public