SAP Knowledge Base Article - Public

3567756 - Mass Change to update field is Completing with Errors due to Field Visibility

Symptom

  • An attempt to perform a mass change to update "field - A" results in completion with errors.
  • The error message displayed is: "This scheduled job failed to complete. For details, please contact SuccessFactors customer support. java.lang.NullPointerException: Cannot invoke "com.successfactors.hris.bean.model.HrisElementField.getLocalizedLabel()" because "field" is null."

Environment

SAP SuccessFactors Employee Central

Reproducing the Issue

  1. Navigate to Manage Mass Changes.
  2. Click Create New and populate the mass change details.
  3. Once the mass change status is completed, click on the completed with errors status and note the error message.
  4. Error =  java.lang.NullPointerException: Cannot invoke "com.successfactors.hris.bean.model.HrisElementField.getLocalizedLabel()" because "field" is null.

Cause

The issue is due to the visibility configuration of the field "field - A", which is configured with "visibility=VIEW" in Manage Business Configuration.

Resolution

  1. If the change has to be made through Mass Changes, change the visibility to "EDIT".
  2. Alternatively, use "Employee Data Import" to change the field's value. For import to work, the field with visibility=view should have -  Allow import = "Yes".

See Also

2092850 - Massive Changes to Employee Data via Import - Employee Central - SAP for Me

Keywords

SAP SuccessFactors, Employee Central, Mass Change, EEO Category, Visibility, Error, NullPointerException, Employee Data Import, Field Visibility, Cannot invoke "com.successfactors.hris.bean.model.HrisElementField.getLocalizedLabel()" because "field" is null, Failed, getLocalizedLabel , KBA , LOD-SF-EC-EDP , Import Employee Data (EC Core only) , Problem

Product

SAP SuccessFactors Employee Central all versions