SAP Knowledge Base Article - Public

3567765 - Workflow contributors are not receiving any E-mail Notifications When a Comment is Posted on a Workflow

Symptom

Workflow contributors are not receiving any E-mail Notifications When a Comment is Posted on a Workflow

Email Notification Templates cannot be sent because of configuration warning message such as:
"You do not have a template created for the selected language, this is the recommended XXXX locale template"

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental. 

Environment

  • SAP SuccessFactors Employee Central
  • SAP SuccessFactors HXM Suite 

Reproducing the Issue

  1. Go to test user's Job Information and select 'Edit'
  2. Fill the relevant data
  3. SelectSave
  4. Workflow Triggers
  5. Proxy as the Approver
  6. Make a Comment on Workflow ( Mail should be sent as per the Workflow-Configuration-Settings)
  7. Approve the workflow
  8. E-mail should be sent to HR but no email was received.

Note:

  • The Workflow-Email-Config should always send a Mail to the Contributor if a Comment is published.
  •  E-mail notifications should be sent when a workflow is initiated.

Cause

  • Configuration issue 
  • For this example: template not save with warning message:  You do not have a template created for the selected language, this is the recommended English UK ‎(English UK)‎ locale template. 

Step 1:

  1. Go to: Change Email Notification Setting
  2. Check Contributor: First and Last name 
  3. Check if: Email Notification is : On/Enabled

    Step 2:

    1. Go to : Email Notification Templates 
    2. check: Workflow Comment Posted Notification 
    3. result: 
    4. template Not save
    5. See Issue: You do not have a template created for the selected language, this is the recommended English UK ‎(English UK)‎ locale template. 

    Note: The specific email notification is not enabled to trigger emails.

    • Admin Center > Company Settings > E-Mail Notification Templates Settings
      Options > Notifications (if you are the affected user)

    Resolution

    Email Notification Templates must be initialized in the instance on first use. If this is not carried out, you will not receive the emails in all enabled locales.

    • To check if an email template is not initialized, navigate to the template for the desired locale.
    • You will then see a warning message stating "You do not have a template created for the selected language, this is the recommended XXXXX locale template".
    • To initialize this template please make any required changes to the template and save the template:

    Note: You must have saved all Available E-mail Templates for Employee Central Workflows required for business 

    FAQ - Additional Information

    Q) Where can I get Guide?

    A) Guide: Employee Central Workflows: Implementation and Administration

    Chapter: Available E-mail Templates for Employee Central Workflows

    See Also

    • 2287616-List of tags supported in workflows and EC Alerts and Notifications.
    • 2254895 - The tag [HRIS_ACTION] is not translating as expected in Email Notifications.
    • 2436866 - How to change the value [[EVENT_REASON]] for Time Off Requests
    • 2087440 - Disabling Email Notifications For One or More Users for an Instance
    • 2087890 - Top Reasons Why Email Notifications are Not Sent or Received. Basic Troubleshooting - HXM Suite 
    • 2358563 - Workflow Email not being sent to all cc recipients
    • 2446500 - How is the Recipients local Determined for Workflow Emails and Alerts and Notifications
    • 2632511 - Workflow Participant Receives two Email Notifications for the Same Workflow
    • 2087739 - Single Sender and Single Recipient | How They Work and How to Set Them Up
    • 2080108 - Workflow Role Types - Employee Central 
    • 2308572 - Email Notification Templates and their Target Recipients
    • 2087440 - Disabling Email Notifications For One or More Users for an Instance

    Keywords

    You do not have a template created for the selected language, this is the recommended English UK ‎(English UK)‎ locale template, workflow, Change Email Notification Setting, Company Settings, email, Company Settings, Available E-mail Templates for Employee Central Workflows, Workflow Comment Posted Notification, Workflow Action Contributor Notification , Workflow Action Approval Notification  , KBA , LOD-SF-EC-WFL-CUS , Custom Workflow Notifications , Problem

    Product

    SAP SuccessFactors HCM Core 2411