Symptom
An error occurs when attempting to post a Billing Document. The error message displayed is "Service Document Item &1/&2/&3 has an incorrect status."
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Open "Manage Billing Documents".
- Enter Billing Document number in the search bar.
- Click into the Billing Document and try to post it.
- The error "Service Document Item &1/&2/&3 has an incorrect status." occurs.
Cause
- The "Account Assignment Group for Customer" (Acct Assmt Grp Cust.) field in the billing document was found to be blank.
- This missing value prevents the system from determining the correct General Ledger (G/L) accounts for revenue posting in accounting.
Resolution
- Update Billing Document in VF02
- Go to Change Billing Document, enter Billing Document Number, and press Enter.
- Navigate to Header Data > Accounting Tab.
- In the field "Acct Assmt Grp Cust.", select the appropriate value:
- Domestic Revenues (if local)
- Foreign Revenues (if export)
- Click Save.
- Post the Billing Document.
Keywords
SAP S/4HANA Public Cloud, Public Cloud, Billing Document, Posting Error, Incorrect Status, Service Document Item, Account Assignment Group for Customer, VF02, Acct Assmt Grp Cust., Domestic Revenues, Foreign Revenues, FCO_SRVDOC, 040. , KBA , CRM-S4-SRV-BIL-2CL , S4CRM: Billing in Service Management (Public Cloud) , Problem
Product
SAP S/4HANA Cloud Public Edition all versions