Symptom
Administrator User is not able to change their personal data, for example the e-mail. Also, the user is not being find as an Employee.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Click on your profile picture > click on the user name.
- Click on edit.
- The E-mail field is not editable.
Or
- Go to Administrator > Business Users.
- Search and select the user.
- Click on Edit > Attributes.
- Some fields (as the E-mail) are not editable.
Cause
The Administrator user was not created as an Employee and therefore it is only a Service Agent. Due to that its data can only be changed in Service Agent Work Center.
Resolution
Please follow below steps to edit Administrator User data:
- Go to Business Partners > Service Agents.
- Open the Administrator user.
- Click on edit.
- Fields like E-mail will be editable now.
The same screen can be opened from below steps:
- Administrator > Business Users.
- Search for and select the user.
- On panel below, click on the user name.
- Service Agent screen will be opened.
See Also
Please refer to SAP Help Portal Use Initial User to Maintain Basic Configuration for more details on Administrator User as a Service Agent and as an Employee.
Keywords
greyed out, grayed out, read only, read-only, email, address data, general data, WC, WoC, workview, work view, workcenter, cannot find, not found, unable, not possible, impossible, modificable, unchangeable , KBA , LOD-CRM-EMP , Employee , LOD-LE-BP-BP , Business Partner , Problem