SAP Knowledge Base Article - Public

3568639 - Sales Order Remaining in "Open" Status after Rejecting all Items in SAP S/4HANA Cloud Public Edition

Symptom

When a sales order with item category TAD is set to "Reject All Items" in the "Manage Sales Orders" app, the overall status of the sales order is not changed from "Open" to "Completed".

Environment

SAP S/4HANA Cloud Public Edition

Reproducing the Issue

  1. Open the "Manage Sales Orders" app or the "Manage Sales Orders - Version 2" app.
  2. Select a sales order with item category TAD and click the "Reject All Items" button.
  3. The rejection status is displayed correctly as "Everything Rejected", but the overall status remains "Open" instead of changing to "Completed".

Cause

This is standard behavior. The overall status in the sales order header is always determined from the overall processing statuses of the items. The overall status of an item is calculated based on the individual statuses of an item (delivery status, billing status). If the sales order is not relevant to both the billing status and delivery status, the overall status will be shown as "Open".

Resolution

The item category TAD (service item) is not relevant for delivery processing; only the billing status is determined. Therefore, once the reason for rejection "Reject All Items" is set, the billing relevancy is removed. In this case, the sales order is in a state where both the billing status and delivery status are "not relevant", which causes the overall status of the sales order to remain "Open".

Keywords

SAP S/4HANA Cloud Public Edition, Manage sales order, Sales order, Item category, TAD, Service, Item, Reject all items, Reject, Everything rejected, Overall status, Open, Completed, Delivery status, Billing status, Billing relevancy, Delivery processing , KBA , SD-SLS-GF-ST-2CL , Status management (Public Cloud) , Problem

Product

SAP S/4HANA Cloud Public Edition all versions