Symptom
- An error message "Saved Failed: Your entries could not be saved due to errors." is displayed when attempting to enter and save a timesheet on behalf of another employee.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to Manage My Area work center
- Go to Call Employee Services On Behalf.
- Select the relevant employee
- Go to "Edit Time Sheet".
- Book time for any activity.
- Choose Save.
- The error message is displayed "Saved Failed: Your entries could not be saved due to errors.".
Cause
- The issue is due to the time type showing as blank while booking the Employee Self Service (ESS) timesheet.
- This is because the default time type for the International time type is not maintained in the Business configuration.
Resolution
If the configuration is maintained then while recording the time entry the time type gets filled automatically by the default time type.
Follow the below steps to maintain the configuration:
- Go to Business configuration work center.
- Select Overview.
- Search for "Default Values for Time Recording - International".
- Select View.
- Update the Default Value for Time Recording using Service Product .
- Save and close.
Keywords
Timesheet, Error, Failed Save, Default Time Type, Substitute, Employee Self Service, ESS, Call Employee Services On Behalf , KBA , SRD-HR-TLM , Time and Labour Management , Problem
Product
SAP Business ByDesign all versions