Symptom
Getting Error "Your entry is too long, Do not enter more than 35 character(s)." when open an account overview.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Open the account 123;
- You see error message "Your entry is too long, Do not enter more than 35 character(s)." appears at the top.
Cause
There are multiple reasons for the error message; this error message may occur when loading UI screen with validation on a specific field. The specific validation needs to be checked by the corresponding team which own the screen.
If with Utilities integration enabled in C4C, one possibility is the error shows during the load of Utilities Alerts in account overview facet, then it may due to validation on the field "External ID".
For standard C4C Utilities solution integration, we support standard back-end systems, ECC and S/4HANA.
If integration with a different back-end system where external ID length more than 35 characters, then it getting loaded in the screen, which will cause such issue.
Resolution
This is system standard behavior.
Kindly change the field value (e.g. external ID) length to less than 35 characters.
Keywords
account, external ID , KBA , LOD-CRM-IND-UTL , Utilities , LOD-CRM-ACC , Account , Problem