SAP Knowledge Base Article - Public

3568803 - Behaviour of Lock Error When Two Different Users Edit The Same Screen.

Symptom

When two different users edit the same screen at the same time the lock error does not occur, and the users do not see the update done by one other.

Environment

SAP Cloud for Customer

Reproducing the Issue

1.User A Edits the ticket header fields without entering the global edit mode.

2.User B tries to edit the same screen at the same time as user A and wants to enter the internal memo.

3.User B does not see that the header has been changed and there is no lock error too.

Cause

From the UI framework point of view, we set the LOCK to prevent concurrent changes ONLY if a MODIFICATION is sent. i.e If you are editing a text - the text should go as a change in 'flat data' in the request. In this case when you edit the text, no changes are sent.

But after editing the text, for example if you navigate to a different facet or trigger any round trip, the change is sent and the ticket instance is LOCKED.

The same behavior can be seen for some code fields too. As per the modeling, if the property 'Requires Round Trip' is set to true, a modification is sent as soon as you make any changes. But if that property is false, modification is NOT sent immediately. So, from an end user perspective, it is better to click on the global EDIT if concurrent changes should not be allowed. 

Resolution

This is an expected behavior it is recommended that the user use global edit option to edit fields and enter any internal notes.

Keywords

Lock error, Global edit , KBA , AP-RC-UIF , C4C UI Framework , Problem

Product

SAP Cloud for Customer core applications 2411