Symptom
The error message states "Journal entry * does not exist" when trying to reverse journal entry in app Manage Journal Entries.
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Open the Manage Journal Entries app.
- Locate and open the journal that needs to be reversed.
- Click on Reverse.
Cause
The issue arises due to a combination check of ledger and company code when reading a reversal document view. For example the ledger of the header level for reversal document is initial, while for corresponding user there is restriction set for ledger with value 0L, then there is no authorization for this specific to display the reversal document.
The authorization issue happens after calling the reversal document. So reversal is successful, but user has no authorization to display reversal document.
Resolution
In the restriction of business role assigned to relevant user, change the ledger restriction from 0L to *(Unrestricted), this can be configured in app Maintain Business Users.
Keywords
Manage Journal Entries, Reverse, Error, Journal Entry, Ledger, "Journal entry * does not exist". , KBA , FI-FIO-GL-TRA-2CL , Transaction Apps (Public Cloud) , Problem
SAP Knowledge Base Article - Public