SAP Knowledge Base Article - Public

3569671 - Process Insights connector connection failed

Symptom

SAP Signavio Process Insights Connector Error:

"Connection failed. Provide updated credentials if you have edit permission for connections."

"Connection failed. Try to check the validity again or provide updated credentials: Checking credentials: rejected. Reason: HTTP protocol error. 404 Not Found."

Cause

Wrong Client Secret, service root or Oauth access token URL. 

Resolution

Make sure to use the correct Service Root and OAuth Access Token Url. Your service key file will determine what region URL you will use in this guide:

https://help.sap.com/docs/signavio-process-intelligence/user-guide/service-root

Service Root example: https://bpi-plug-and-gain.cfapps.<region_ID>.hana.ondemand.com/api/<service>/v1/

With the OAuth Access Token Url you are taking the uaa.url property of the service key details and then adding the suffix /oauth/token. So the pattern is: <uaa.url from service key>/oauth/token

OAuth Access Token Url example: https://<uaa.url>.authentication.<region_ID>.hana.ondemand.com/oauth/token

Just note that if you try using the "Validate" button more times. There is known bug with this button (which is fixed in the new creation flow), when the data shown are retrieved from DB from the previous try.

Keywords

Process Insights Connector, PI, Process Intelligence , KBA , BPI-SIG-PI-DS , Data Source (CSV, Connector) , Known Error

Product

SAP Signavio Process Intelligence all versions