Symptom
The localized product name is not populated in service contracts even though localization is maintained for other languages.
Environment
SAP S/4HANA Cloud Public Edition
Cause
The backend processing logic of the item creation for service contracts is different from sales orders. The product field for service contract items is designed as a free modification field. When creating a service contract item, the product name is populated as the default value to the column "DESCRIPTIOM1" in the "CRMS4D_SERV_I" which displays as "Product" in the frontend UI. After the item creation, the user is allowed to freely change the value of "Product" which means the "Product" field is not associated with the "Product ID" actually. Hence, it's the current expected behavior that the "Product" displaying language will not be changed according to the environment language.
Resolution
Change product names for service contracts manually.
Keywords
Service Contract, Material Translation, Language, Product Name, Product ID, Product, Localization , KBA , CRM-S4-SRV-CTR-2CL , S4CRM: Service Contract (Public Cloud) , Problem