Symptom
When clicking the "Train" button to train a model for SALESVOLUME001 in the "Intelligent Scenario Management" app, the below error displays and the Dataset Record Count displays as 0.
Error Message: We've noticed that your training dataset does not contain any records. To successfully train an intelligent model, you need to have a sufficient number of records in your training dataset.
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Navigate to the "Intelligent Scenario Management" app
- Select the training scenario "SALESVOLUME001" (Sales Performance - Prediction)
- Select a model and click the "Train" button
Cause
This error is due to a lack of data input. A successful training requires a sufficient amount of data. Insufficient data may result in a failed training.
Resolution
According to the Recommendation part in the Help Portal Sales Performance – Predictions > Key Features,
- Ensure that a sufficient amount of data is provided for the training model. The data should be reasonably distributed among key business dimensions such as customer and product.
- Conduct the training only after the systems, especially newly installed systems, contain a sufficient volume of business data.
- It is recommended to provide at least 2000 data records every time the model is trained.
See Also
- Help Portal: Sales Performance – Predictions > Key Features
- Community Blog: How the data predicted in “Sales Performance - Predictions”
- Scope item: Predictive Analytics Model Training - Sales (2YJ)
- Fiori Apps Library: Sales Performance - Predictions (App ID: F3304)
Keywords
Sales Prediction, Training Dataset, No Records, Error, Intelligent Scenario Manager, Sales Performance, SALESVOLUME001, Predictive Analytics Model Training, 2YJ, F3304, Dataset Record Count. , KBA , SD-FIO-HBA-2CL , Analytical Apps (Public Cloud) , Problem