SAP Knowledge Base Article - Public

3569798 - How to troubleshoot network connectivity issue while creating imported universe connection in SAP Analytics Cloud (SAC) ?

Symptom

Creating imported universe connection failed with following error in SAP Analytics Cloud (SAC):

  • Unable to connect to the system, Please specify the correct host information and check for network issues.

Environment

  • SAP Analytics Cloud (Enterprise)
  • SAP Business Intelligence 4.3
  • Imported SAP Universe connection

Reproducing the Issue

  1. Logon to Central Management Console (CMC) for the Business Intelligence Platform (BIP)
  2. Navigate to Servers > find Central Management Server (CMS) > open Properties page
  3. Uncheck Auto assign for Request port, give an exact request port for the CMS server. (e.g. assign 7400 for request port)
  4. Save and restart CMS.
  5. Logon to the machine hosting C4A_AGENT, run the following command:
    • telnet [IP for BIP server] 6400
    • telnet [IP for BIP server] 7400
  6. Confirm telnet to CMS request port and CMS name port is working on the machine hosting C4A_AGENT.
  7. Try to create acquired SAP Universe connection failed with error:
    • Unable to connect to the system, Please specify the correct host information and check for network issues.

Cause

It's requested to check if Network issue blocks the connection creation.

Resolution

- It's important to firstly assign CMS request port manually and confirm telnet to both CMS request port and CMS name port is working, otherwise please check the Reproducing Steps in this KBA before applying the following resolution.
- Wireshark is a free, 3rd party tool which can capture TCP/IP packets through communication passing. This tool itself is not supported by SAP and the following steps are for verifying the connectivity issue only.

  1. Install Wireshark on either BIP server or the server hosting C4A_AGENT.
    Wireshark can be downloaded at: Wireshark · Download 
    Choose all components to install and keep other settings as default.
  2. Open Wireshark after installation.
  3. From menu go to Capture > Start
  4. Create a new acquired universe connection in SAC.
  5. Stop capturing packets in Wireshark.
  6. Filter the trace by either IP of the BIP server or server hosting C4A_AGENT 
  7. In the following example, IP1 is for the server hosting C4A_AGENT and IP2 is for BIP server.
    TCP/IP connection established on 6400 (CMS name port) and 7400 (CMS request port)

See Also

  • 1370469 - How to perform a TCP trace with Wireshark
  • 1969914 - Packet scanning tutorial using wireshark

Keywords

Universe, WebI, Web Intelligence, BO, BI, BIP, connection, imported, SAP Agent, SCC, cloud agent, acquire connection , KBA , LOD-ANA-AQU-UNV , SAC Acquiring Data Universe , Problem

Product

SAP Analytics Cloud 1.0