Symptom
On replicating sales order from external On-premise system to C4C, Opening the sales order shows an error "Item X contains errors".
Environment
SAP Cloud for customer
SAP ERP
SAP S4HANA
Reproducing the Issue
- Go to the Sales workcentre
- Go to the Sales Order view
- Open the relevant replicated order
- You will see the below error (example)
"Item 10 contains errors" shows for a line item (10, 20, etc.) but it is not clear what the error is/means.
Cause
When the Sales order was created some master data inconsistency existed and order item(s) 10 and 20 were marked as inconsistent.
Now even though the master data seems ok, the order items are still inconsistent.
This is why the system indicates the error about the order item consistency status without being able to provide a reason why.
Resolution
You can send an update on the sales order again by an integration message from the connected external system,
The consistency status will be recalculated and set accordingly.
Keywords
Sales order, item inconsistency, product item , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , Problem
SAP Knowledge Base Article - Public