Symptom
After importing the third-party I-9 data through the manage data page for Onboarding, the I-9 Section 3 Reverification tasks are stuck in a loop and cannot be completed.
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- Import the third-party I-9 data through the manage data page for Onboarding.
- Log in as I-9 responsible user.
- Complete I-9 Section 3 Reverification task.
- I-9 Section 3 Reverification task disappeared.
- Run I-9 trigger job;
- The I-9 Section 3 Reverification task is created again for the same employee.
Cause
The SeqNo for the imported I-9 Audit Trail records is incorrect.
The application is designed to assign SeqNo based on the count of I-9 Audit Trail records, which should be 1 when importing it. This logic was violated, resulting in the looping creation of the Reverification process.
Resolution
When importing I-9 Audit Trail records, make sure to assign the SeqNo as 1.
Keywords
I-9 Section 3 Reverification loop, I-9 Reverification, import I-9 data, third party I-9 data, Reverification loop, I-9 trigger job, I-9 Audit Trail record, eligibility expiration date
, KBA , LOD-SF-OBX-I9 , i9 Compliance Form , Problem