SAP Knowledge Base Article - Public

3570859 - Crystal Reports List of Values Not Working After Promotion

Symptom

  • The List of Values (LOV) in Crystal Reports is not functioning as expected.
  • The issue occurs after the promotion of the LOV.
  • The LOV appears empty when trying to refresh the report in BI Server of Crystal Reports 2020.

Environment

  • Crystal Reports designer
  • Business View Manager
  • SAP BI 4.3 SP4 Patch 8

Reproducing the Issue

  1. Refresh the report in BI Server of Crystal Reports 2020.
  2. Observe that the list of values is empty.

Cause

The issue is caused by a broken security relationship between LOV objects.

Resolution

  1. Identify that the LOV is based on Business View.
  2. Note that the report based on the same Business View is also empty.
  3. Decide to recreate the objects.
  4. Create a New Data Foundation based on the same Data Connection SMGR_DC. Copy the Command object from the original DF.
  5. Create a new Business Element based on the new Data Foundation.
  6. Create a new Business View based on the new Business Element.
  7. Right-click the Original LOV and select Change Business View. Ensure the LOV is not scheduled. Clear the instance. Point the LOV to the new Business View.
  8. Test the report to confirm it works.

See Also

  • KBA for reference: [2358049 - How to troubleshoot Crystal Reports Dynamic Parameter List of Values (LOV)?](https://i7p.wdf.sap.corp/sap/support/notes/2358049)
  • For the side question: How to remove the patches from LOV prompt - refer: [1381361 - Dynamic Parameter List of Values are displayed in batches in Crystal Reports and in SAP BI LaunchPad](https://me.sap.com/notes/1381361)

Keywords

Crystal Reports, List of Values, LOV, Promotion, Empty LOV, BI Server, Business View, Data Foundation, Business Element, Change Business View, Troubleshoot, SAP BI 4.3 SP4 Patch 8. , KBA , BI-RA-CR , Crystal Reports designer or Business View Manager , Problem

Product

SAP Crystal Reports all versions