Symptom
- The Display Name of users, which were purged and reactivated later, are showing as "Purged User" instead of the Display Name configuration.
- When searching for a user that was reactivated after purge, "Purged User" is displayed as a result instead of the Display Name configuration.
- How to update the "Purged User" value that is displayed as Display Name of a user that was reactivated after a purge?
“Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.”
Environment
SAP SuccessFactors HCM Suite
Reproducing the Issue
- Purge a user through DRTM Master Data Purge.
- Reactivate the same user following the steps outlined in KBA 2392094.
- When searching for this user, observe that the Display Name is showing as "Purged User" instead of the Display Name Configuration:
Or, export the User Data File and observe that the user has "Purged User" under the Display Name column:
Cause
When you reactivate a purged user through the import process outlined in KBA 2392094 and don't maintain the Display Name column and desired value in the import file, Display Name is populated with the "Purged User" value.
Resolution
- If the affected user is an EC user, go to Company System and Logo Settings and click on Refresh General Display Name. The Refresh General Display Name will trigger an HRIS Sync and once the job is completed you can verify the Display Name of the affected user. For more information about Refresh General Display Name, please refer to Refreshing General Display Name Help Guide.
- If the affected user is not an EC user, you can update the Display Name through the Import and Employee Data tool > Basic Import. For non EC users the Display Name can also be maintained in the import file during the process of reactivating the purged user.
Important Note: as outlined in Help Guide Configuring General Display Name, it is not recommend Employee Central customers to update the Display Name field value through import, because the updates will be overwritten by HRIS sync or when you refresh the general display name.
How to verify if a user is an EC user or is not an EC user?
- Got to Data Inspector
- Select Table_EMP_EMPLOYMENT_INFO from the Entity dropdown
- Click on Add Field Criteria and inform User Sys ID + Equals + affected User ID and click on Show Data:
If the value under "Is EC Record" is 0, the affected user is not an EC user. If the value is 1, then the affected user is an EC user.
See Also
Configuring General Display Name
Refreshing General Display Name
3261324 - General Display Name Troubleshooting
2392094 - Re-activate a Purged User Via Employee Import Feature
Keywords
Display Name, Purged User, Reactivated User, EC User, Non EC User, Refresh General Display Name, Import and Employee Data tool, Basic Import, UDF, Soft Purge , KBA , LOD-SF-PLT-UIM , Employee Import Issues , LOD-SF-PLT-DRM , Data Retention Management , How To