Symptom
"Check for Duplicate" Button is not available for specific user ,but it's visible for admin user.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Customers Work center.
- Accounts view.
- Open any accounts.
- "Check for Duplicates" is not available.
Cause
The duplicate check in the account QC should help to identify a potential duplicate while creating a new account.
For the duplicate check in the TI the use case is different, there the account was already created/does already exist. In the TI the duplicate check should help to identify for the already existing account potential duplicates as a pre-requisite to create a merge case. This is the reason why the button is only visible for users having the 'customer merge' view assigned.
The more precise label would be "Perform duplicate check to create a merge case", but this is too long for a button description.
Resolution
- Go to administrator Work Center.
- General Settings work center view.
- Business Roles .
- Select the affected business role.
- Edit.
- Work center and view assignments.
- Find.
- Customer Merge
- Assign Data Cleansing work center and Customer Merge view.
See Also
Keywords
Account, Check for Duplicate ,Customer Merge, Duplicate Check. , KBA , LOD-LE-BP-DUP , Business Partner Duplicate Check , Problem