Symptom
- An attempt to upload around a lot of Business Partners (BP) records in SAP CPQ was partially unsuccessful.
- Only some of them were successfully uploaded, but the job status shows as Finished on the Bulk import/export page.
Environment
Sales Cloud CPQ
Reproducing the Issue
- Go to Setup in SAP CPQ.
- Navigate to Import/Export.
- Select Bulk Business Partner Import/Export.
- Upload the excel file containing records.
- After the job completes, search for any of the BPs from the uploaded records in the system and they're missing.
Cause
The Excel sheet contained multiple records with duplicate System IDs. As SAP CPQ requires System IDs to be unique, these duplicates caused import errors.
Resolution
- After uploading a file and completing the import job, download the corresponding Import job report to review the process.
- Look for rows highlighted in red in the report. These rows represent errors encountered during the upload.
- Scroll to the last column of a red row to find an error message stating: "System ID must be unique."
- Ensure that the System IDs are unique before the next import.
See Also
Keywords
SAP CPQ, Business Partner, BP, Upload, Import, Duplicate, System ID, Import Job, Error, Unique, Report. , KBA , CEC-SAL-CPQ , Sales Cloud CPQ , Problem
Product
SAP CPQ all versions
SAP Knowledge Base Article - Public