Symptom
During the onboarding step, an error occurs when trying to submit an E-Verify case. The error message indicates that the Social Security Number (SSN) does not conform to the required pattern, even though it appears to be correctly formatted.
The error message is: "E-Verify encountered data errors. Please contact Product Support with the following error details: ssn: Invalid value for "ssn", must conform to the pattern /^(?!123-45-6789|111-11-1111)\d\{3\}-\d\{2\}-\d\{4\}$/."
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- During the onboarding step, attempt to submit an E-Verify case.
- Encounter an error message indicating that the SSN does not conform to the required pattern.
Cause
The cause of the issue is a space after the SSN number.
Resolution
In order to solve this:
- Go to Manage data
- Search for "E-Verify Data" with the relevant userId
- Take action
- Remove the space on SSN number
- Save
See Also
Keywords
E-Verify, SSN, Invalid value, SAP SuccessFactors Onboarding, Error, Pattern, Data errors, Manage data, Space, encountered, data, errors, Please contact Product Support with the following error detail, Invalid value for "ssn", must conform to the pattern, /^(?!123-45-6789|111-11-1111)\d\{3\}-\d\{2\}-\d\{4\}$/, obx, onb , KBA , LOD-SF-OBX-EVF , Everify , Problem