Symptom
A "NotFound" error shows up for a user when opening User Settings in Groupware Settings. The user previously could access the workcenter without issue.
Environment
SAP Cloud For Customer
Cause
The most likely cause of this, that the user External ID has been changed. For the Server Side Integration with outlook, the External ID is the user email.
As a result, when the request is sent to open the user settings the new email is checked for, but it will not match the email in the database which is the previously used email. Hence, the user is not found, triggering "NotFound" error.
Resolution
To resolve this issue, it’s best to reprovision the user to ensure the new data is loaded correctly. This can be done by removing the user from the tenant via Groupware Settings and then provisioning them again.
This will ensure the new email is added to the database and now will match with the new user email.
Keywords
Groupware, Server Side, SSI, User Settings, C4C, Email, NotFound , KBA , LOD-CRM-GW-SCC , Invisible CRM - Smart Cloud Connect Solution , Problem