Symptom
When the ISO code of the bank country and the IBAN country code do not match, the system populates the error message BF00 025 "The bank country and ISO code of the IBAN are not identical". This validation check does not allow to enter IBAN from some countries or territories, where the IBAN country code and the bank ISO country code differs.
Environment
SAP S/4HANA Public Cloud Edition
Reproducing the Issue
- Enter App 'Maintain Business Partner'.
- Enter Business Partner and select 'Switch between Display and Change'.
- Under 'Payment Transactions' enter Bank Details (ID, country/region key, Bank Key, Bank Account).
- Maintain IBAN number and save it.
- System is not saving the IBAN number due to error: "Bank country/region and ISO code of the IBAN are not identical".
Cause
According to the error message the ISO code of the bank country does not agree with the ISO code of the country of the IBAN.
For example the ISO country code of Isle of Man is 'IM', but the IBAN country code is 'GB'. The ISO country code Reunion is 'RE', but the IBAN country code is 'FR'.
Resolution
Check the countries specified in the bank details and in the IBAN.
Check IBAN validity https://www.iban.com/iban-checker
See Also
Keywords
IBAN, ISO code, BF00025, BF0 025, bank country, country code, country/region key, business partner, business master, bank details, BP , KBA , CA-BK-2CL , Bank (Public Cloud) , Problem