SAP Knowledge Base Article - Public

3572148 - The "Department" field is not available as a Condition when creating a Workflow rule for object "Contact"

Symptom

You are trying to create a workflow rule for Contact (or custom) where the field you are trying to reference is the "Department" field under the Contact view.

However, in step 2 (Defining Conditions), there is no option to select the "Department" field as a parameter condition.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to Administrator WC > Workflow Rules
  2. Click New
  3. Enter basic data and select business object "Contact" or whatever custom view you want to use, and set the timing per requirements
  4. In step 2, add a new condition group (at this point, the expectation is to see the "Department" in the dropdown list as a condition), but such option is not available for selection

Cause

Currently, the "Department" the field is not available to be used as condition in the Workflow Rule.

Resolution

If the feature/functionality is required urgently, please refer to KBA 3475641 - Functionality Currently not Available.

An alternative option may be to check the corresponding SAP Customer Influence Site to submit an idea:

As a workaround, you may also create conditions using custom (adapted) field:

See Also

3141778 - The "Function" field is not available as a condition when creating a workflow rule for object "Contact"

Keywords

KBA , LOD-CRM-WKF , Workflow , LOD-CRM-CON , Contact , Problem

Product

SAP Cloud for Customer core applications 2502