Symptom
Whilst creating a Point-Of-Sale Transaction via the web service PointOfSaleTransactionProcessingPointOfSaleTransactionIn, lower case letters input into the tag ExternalID are converted to upper case.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to work centre: Application and User Management.
- Select view: Communication Arrangements.
- Select the relevant arrangement for Point-Of-Sales Transactions then download the WSDL.
- Run a sample request with <ExternalID>tEsT123</ExternalID>.
- Go to work centre: Customer Invoicing.
- Select the view: Sales Transactions.
- Search All Sales Transactions: tEsT123.
No results found.
- Now search All Sales Transactions: TEST123.
The transaction's External ID is all capitalized as follows "TEST123".
Cause
The system is designed to convert the ExternalID in the Point-of-Sale Transactions to upper case. This cannot be configured otherwise in the system.
Resolution
As a workaround the <Note> tag in the web service can be used to pass the External ID in a mixture of upper and lower case.
E.g. if you include <Note>tEsT123</Note> in the payload it will retain upper and lower case and will be displayed in the UI as Document Header Text.
Keywords
SAP, web service, Point-Of-Sale Transaction, ExternalID, Mixed Case Alphanumeric, API, Web Service, Note, Tag , KBA , AP-CI , Customer Invoice Processing , Problem