Symptom
How to turn a field mandatory in the mobile app.
Environment
- SAP Sales Cloud V2
- SAP Service Cloud V2
Reproducing the Issue
- Login in the App
- Go to the desired entity
- Click to create a new entry
Result: the field appears as non-mandatory but it should be appearing as mandatory
Cause
To a field appear as mandatory in the Mobile App, it should be set as "Required" in the Extensibility Administration Configuration.
Resolution
- Go to the Settings > All Settings
- Open "Extensibility Administration"
- Select the entity and click on the tab "Field Attributes"
- Look for the field that need to be set as mandatory
(If the field no appear on the list, make sure that the toggle "Show Only Custom Fields" is disable) - Expand the properties and look for the column "Required"
The field needs to have this toggle enabled to appear as mandatory.
Note: When marking a field as required, the change will be reflected in the UI and in the Mobile app.
In case it only appears as "Mandatory" in one of the options (UI or App), please raise a case for the support team.
Keywords
App, Mandatory, Extensibility Administration, Non-Mandatory, Mobile, Entity, Field, Requested, Required , KBA , CEC-CRM-MOB-ADM , Mobile Administration for SAP Sales/Service Cloud , How To