Symptom
Status a field in BenefitEmployeeClaim entity which has a value populated in the UI, but when viewing it via Integration Center, the value returned is blank.
Environment
- SAP SuccessFactors HXM Suite
- Integration Center
Reproducing the Issue
- Create a Scheduled Simple File Output Integration.
- Select the starting entity as “BenefitsEmployeeClaim”.
- Select the field as per requirement also select the status field.
- Open the IC job preview.
- See the field Status for which values are coming as blank in IC job preview on UI you can see the values for this field.
Cause
The “status” field in Benefit employee claim object is not in use. Also, this field is not for storing the workflow status. Due to which when you are checking the status field in the Integration Center it is coming as blank.
Resolution
To check the status, you can refer the workflow status.
For workflow status, you can use Record Status(recordStatus) field.
In the IC job which you have configured you can use the field as "recordStatus" which shows the status of the workflow.
If the workflow is Approved, then the recordStatus would be N.
See Also
BenefitEmployeeClaim | SAP Help Portal
3052906 - A field's value is visible in the user interface, but appears as null (blank) when queried via OData API or Integration Center - SAP SuccessFactors HCM Suite - SAP for Me
Keywords
BenefitEmployeeClaim, visible, status field, status, recordStatus, N, visible, null, blank , KBA , LOD-SF-INT-INC-JOB , Integration Center Job , Problem