Symptom
The E-mail Address is missing from the Involved Parties tab for the Account Party of the Invoice Request.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to Customer Invoicing Work Center.
- Go to the Invoice Requests View.
- Search the Invoice Request ABC and edit (ABC represents the Invoice request ID).
- Navigate to Involved Parties tab.
- Select the Account party.
The Email is missing even though it is maintained in Account Master data of XYZ (XYZ represents Account ID)
The invoice request belongs to a sales order which was created on 26/01/2024 (The date 26/01/2024 is taken as an example for understanding the concept)
Cause
The E-mail address was added in the account master data after creation of source document, this can be verified through the following below steps:
- Go to Account Management work center.
- Go to the Accounts View.
- Open the Corporate Account XYZ.
- Navigate to changes tab.
The email "xxxx@example" was added on 09/10/2024, where the sales order was created on 26/01/2024.
Hence the email address would not be visible in the sales order or Invoice request involved parties tab.
Resolution
This is system standard behavior.
Keywords
E-mail; Accounts; Involved Parties; Customer Invoicing; Invoice Requests , KBA , SRD-CRM-INV , Customer Invoicing , Problem
SAP Knowledge Base Article - Public