SAP Knowledge Base Article - Public

3572638 - SOAP Query Employee Time In Issue with 00:00 Timestamp

Symptom

  • An integration solution using the SOAP Query 'Employee Time In' to retrieve details of a time sheet entry encounters an issue with the '00:00' timestamp.
  • When '00:00' is set as StartTime or EndTime, the value '00.00' is not delivered in the webservice.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Use the SOAP Query 'Employee Time In' to retrieve details of a time sheet entry.
  2. Set '00:00' as StartTime or EndTime.
  3. Observe that the value '00.00' is not delivered in the webservice.

Cause

The issue is associated with the design of the webservice. If one of the times (start or end) is midnight, this time is not shown in the XML/response.

Resolution

  • This matches the current behavior of the webservice which is not designed for this scenario.
  • A related requirement has been added to the Product Backlog. 
  • It is possible to set the midnight start or end time time as '00:00' at the receiving side of the integration.
  • Alternatively it is possible to  book the start/end time as '00:01' and the web service will tag the response.

See Also

Keywords

SOAP Query, Employee Time In, 00:00 timestamp, webservice, StartDate, Enddate, StartTime, EndTime, system behavior, webservice design, integration, time sheet entry, EmployeeTimeIn , KBA , SRD-HR-TLM , Time and Labour Management , Problem

Product

SAP Business ByDesign all versions