Symptom
- After SAP S/4HANA Cloud Public Edition 2502 upgrade, it is no longer possible to open the attachments in the Supplier Invoice List app.
- Attachment added successfully to Supplier Invoice, but an error occurs with 'An exception was raised ' in <service_id>CV_ATTACHMENT_SRV</service_id> when attempting to open it.
Environment
SAP S/4HANA Cloud Public Edition 2502
Reproducing the Issue
- Attachments are uploaded to the supplier invoice receipt via SAP API API_CV_ATTACHMENT_SRV and Entity OriginalContentSet
- The invoice is opened in the app "Supplier invoice list" or another application
- Displaying an attachment does not work.
Cause
The issue is during the creation of attachment via CPI using API_CV_ATTACHMENT_SRV where the Content_Type parameter is coming as Text/Html for every file.
This is not as expected.
Resolution
Please correct the iFlow/CPI to send the correct Content_Type as per the attachment content( for ex: in case of PDF files the Content_type should be application/pdf ), so that the attachment will create as expected and download will work smoothly.
Keywords
PDF , Content_Type , application/pdf , API_CV_ATTACHMENT_SRV , OriginalContentSet , KBA , CA-DMS , Document management , How To
Product
SAP S/4HANA Cloud Public Edition 2502