SAP Knowledge Base Article - Public

3572967 - Placeholder is not working for Workflow E-mail Template

Symptom

It was created a KUT field for the Employee WorkCenter, and added as placeholder for a Workflow Rule. The Workflow is configured to Visits object with Type send E-mail.

The custom field is named "Function", for example, and is filled with the Employee function. In the Rule, it was created a placeholder named #OWNERFUNCTION# and this placeholder was added in the e-mail template.

However the placeholder does not work, as the "Function" is not displayed in the generated e-mail. 

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to Visits > Visits.
  2. Open the related Visit.  
  3. Click on the follow-up items which will be the e-mail sent.
  4. Go to E-mail Viewer tab.
  5. See the Function is not shown, there is a blank space.

Cause

The #OWNERFUNCTION# placeholder is not showing the Function value in the e-mail template, because the Workflow is created for a Visit. Due to that, the placeholders will only display fields related to the Visit itself or its Account. As an exception, it will have the Employee Owner name and Employee Owner ID.

So, the Owner Function can only come from the Account. If check inside the Workflow Rule placeholder options, this KUT field will have the name started with "ACCOUNT_COMMON|[...]", meaning it comes from Account BO.

If the KUT field was available for the Employee, it would show as "EMPLOYEE_COMMON|[...]".

 

 

Resolution

This is the expected system behavior.

As an alternative, this KUT field can be extended from the Employee to the Account BO. But just extending the field is not sufficient as the value won't be passed because Employee and Account are both considered as Business Partners. So additionally, a PDI solution would need to be created to pass the value for the custom field from Employee to Account BO. With this whole picture set, then the Workflow Rule would work as expected, by showing the desired value in the e-mail template. 

If interested in implementing a PDI solution for this, please refer to your Implementation Partner

And to extend the field, follow below steps:

  1. Go to the Account linked to the Visit. 
  2. Go to menu > adaptation mode.
  3. Click on pencil for the header.
  4. Go back a level.
  5. Click on Add > Field.
  6. Search for the KUT field name.
  7. Click on apply.

OBS.: The KUT field and placeholder mentioned are an example. This KBA can apply to different custom fields for this Account/Employee scenario.

Keywords

BP, business user, email, WC, work view, workview , KBA , LOD-CRM-WKF , Workflow , LOD-LE-BP-BP , Business Partner , LOD-CRM-EMP , Employee , LOD-CRM-ACC , Account , Problem

Product

SAP Cloud for Customer core applications all versions